Performance issues impacting Power Surveys [NA2] continued
Incident Report for Alida
Resolved
The performance issues impacting Power Surveys in NA2 is now resolved. Performance has now been restored to normal operational levels. Thank you for your understanding on this matter, we appreciate your patience on this.
Posted Feb 15, 2024 - 03:05 EST
Investigating
We are continuing to see some performance issues with Power Surveys in NA2. You may experience issues accessing, authoring or responding to a Power Survey. We will provide updates as our investigation continues. Once again, we appreciate your patience on this matter and apologize in advance for the inconvenience. Thank you.
Posted Feb 14, 2024 - 19:24 EST
This incident affected: NA2 (Power Surveys).