This incident is now resolved and the delivery rates of emails being delivered to Microsoft domains have returned to normal across all pods. Thank you for your patience while we worked to resolve this issue.
Posted Feb 04, 2026 - 13:07 EST
Monitoring
The delivery rates of emails being delivered to Microsoft domains have returned to normal across all pods. At this time, there may still be some delay in the delivery of these emails. We are continuing to monitor the issue and will provide further updates as soon as it is fully resolved. Thank you for your patience.
Posted Feb 03, 2026 - 16:31 EST
Update
We are continuing to work on a fix for this issue for the remaining pods. Thank you for your continued patience as we work to resolve this.
Posted Feb 02, 2026 - 16:40 EST
Update
This has been resolved for members in the EU1 and EU2 pods. We are continuing to work with Microsoft to resolve the issue for the rest of the pods.
Posted Jan 30, 2026 - 13:26 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 29, 2026 - 10:57 EST
Update
We are continuing investigation of an industry-wide issue affecting email delivery to Microsoft consumer domains (including outlook.com, live.com, hotmail.com).
The changes implemented by our team continue to show improvement and we will continue with this approach until the issue is fully resolved.
Further updates regarding the issue will continue to be provided daily or as we receive them. Thank you for your patience while we work to resolve this issue.
Posted Jan 28, 2026 - 13:34 EST
Update
We are continuing investigation of an industry-wide issue affecting email delivery to Microsoft consumer domains (including outlook.com, live.com, hotmail.com).
Our teams have implemented changes that are improving the situation and will continue with this approach until the issue is fully resolved.
Further updates regarding the issue will continue to be provided daily or as we receive them. Thank you for your patience while we work to resolve this issue.
Posted Jan 27, 2026 - 12:39 EST
Update
We are continuing investigation of an industry-wide issue affecting email delivery to Microsoft consumer domains (including outlook.com, live.com, hotmail.com).
This is not caused by any changes to the Alida platform. Our systems remain fully functional, but delivery to Microsoft recipients is currently restricted by Microsoft.
Our engineers are working directly with Microsoft to resolve this. We are also testing technical workarounds to restore normal mail flow as quickly as possible.
We will continue to provide daily updates on the status of this issue until the issue is resolved.
Posted Jan 26, 2026 - 13:58 EST
Update
We are continuing to work with Microsoft to resolve this issue as soon as possible.
Posted Jan 26, 2026 - 12:37 EST
Identified
Our teams have identified an issue affecting the deliverability of communications to members with email addresses on Microsoft domains (Live, Hotmail, Outlook). Members using the mentioned email providers may not receive invitations and deliverability may show an increase in soft bounces.
Our team is in direct contact with Microsoft case managers working towards a resolution as soon as possible. Thank you for your patience while we work to resolve this issue.
Posted Jan 26, 2026 - 10:17 EST
This incident affected: NA1 / AP1 (Surveys), NA2 (Surveys), EU1 (Surveys), EU2 (Surveys), AP2 (Surveys), and AP3 (Surveys).