NA1 Performance Issues

Incident Report for Alida

Resolved

The degraded performance experienced in NA1 is now resolved. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Sep 08, 2025 - 12:05 EDT

Investigating

We are currently investigating an issue related to degraded performance in the NA1 pod. You may experience errors when working in the Touchpoint application and members may experience issues with the Sign Up Page, Member Hub Login Page and Recruitment Confirmation. Our teams are working to resolve this issue as soon as possible. Thank you for your patience while we work to resolve this issue.
Posted Sep 08, 2025 - 10:54 EDT
This incident affected: NA1 / AP1 (Hubs, Touchpoint).