Performance issues impacting Power Surveys [NA2]
Incident Report for Alida
Resolved
The performance issues impacting Power Surveys in NA2 have now been resolved. Performance has now been restored to normal operational levels. Thank you for your understanding on this matter, we appreciate your patience on this.
Posted Feb 14, 2024 - 17:36 EST
Investigating
We are currently investigating an issue impacting Power Surveys in NA2. You may experience issues accessing, authoring or responding to a Power Survey. We will provide updates as our investigation continues. We appreciate your patience on this matter and apologize in advance for the inconvenience. Thank you.
Posted Feb 14, 2024 - 12:58 EST
This incident affected: NA2 (Power Surveys).