Recruitment Link Error Messages

Incident Report for Alida

Resolved

The error message experienced when accessing recruitment links has been resolved. Thank you for your patience while our teams worked to resolve this issue and we apologize for the inconvenience this may have caused.
Posted Mar 24, 2026 - 10:51 EDT

Investigating

We are currently investigating an issue in which error messages are seen when accessing live and test recruitment links. This issue is specifically impacting recruitment links with identity variables appended, but may also impact recruitment links without identity variables appended. Our teams are looking into this with the highest priority. Thank you for your patience while we work to resolve this issue.
Posted Mar 24, 2026 - 10:32 EDT
This incident affected: NA1 / AP1 (Surveys), NA2 (Surveys), EU1 (Surveys), EU2 (Surveys), AP2 (Surveys), and AP3 (Surveys).