Technical Support Phone and Chat Coverage

Incident Report for Alida

Resolved

This incident has been resolved. Technical Support coverage is operational.
Posted Jul 17, 2026 - 01:20 EDT

Investigating

Hi all,

Please note that Technical Support will be unavailable through the Live Chat and Phone channels from 7 PM PST to 10 PM PST on July 16th, 2026. Our Technical Support team can be contacted via email by submitting your inquiry to support@alida.com. Thank you for your understanding.
Posted Jul 16, 2026 - 17:46 EDT
This incident affected: AP2 (Technical Support Coverage) and AP3 (Technical Support Coverage).