NA2 Performance Issues: AWS Outage

Incident Report for Alida

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:26 EDT

Monitoring

Our teams are currently monitoring the ongoing issues with AWS. You may experience performance issues in the NA2 pod due to these issues. Thank you for your patience.
Posted Oct 20, 2025 - 16:00 EDT
This incident affected: NA2 (Insight Community, Surveys).